Resolved
Android builds failing

Started
November 04, 2022 at 9:00 PM
Status
Resolved after 1 day

Impact

Major outage
Affected
App Publishing
Android
  • Resolved
    November 05, 2022 at 10:09 PM

    This issue is resolved.

  • Monitoring
    November 05, 2022 at 7:00 PM

    We've increased the disk size on our build servers and are seeing builds succeed again. We'll continue to monitor android builds.

  • Monitoring
    November 05, 2022 at 6:53 PM

    We are seeing android builds succeed again and will continue monitoring for any further problems.

  • Identified
    November 05, 2022 at 5:21 PM

    Our work on a solution was briefly paused overnight and we're continuing our work toward a solution as quickly as possible.

    We know the underlying cause of the build failures and are reconfiguring the build system to work around the issue with a third-party dependency.

    Thank you for your patience.

  • Identified
    November 05, 2022 at 6:39 AM

    We've identified the root cause of the dependency issue and are testing a fix.

  • Investigating
    November 04, 2022 at 11:34 PM

    The team is investigating a secondary issue related to dependencies.

  • Identified
    November 04, 2022 at 11:14 PM

    We've identified a likely cause of the build failures and are testing a solution.

  • Investigating
    November 04, 2022 at 9:00 PM

    Android builds are failing due to an issue with a common dependency. We are investigating the cause.