Adalo - Build Error: react-native-video Update Causing App Failures – Incident details

Build Error: react-native-video Update Causing App Failures

Resolved
Partial outage
Started about 3 hours agoLasted about 2 hours

Affected

Publishing

Partial outage from 7:45 PM to 10:00 PM, Operational from 7:45 PM to 10:00 PM

iOS

Partial outage from 7:45 PM to 10:00 PM

Android

Operational from 7:45 PM to 10:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We're aware of a build error affecting Native apps that use the Video component:

    Unable to find a specification for 'NitroModules' depended upon by 'ReactNativeVideo'

    This is caused by a breaking change in a third-party package (react-native-video) that updated roughly 30 minutes ago and introduced a new dependency that isn't compatible with our current build environment.

    We'll update here once we have a resolution.